[elinks-users] Ctrl-S fails to bind

Fabienne Ducroquet fabiduc at gmail.com
Mon Dec 16 23:23:03 PST 2013


Le lundi 16 décembre 2013, Dun Peal a écrit :
> Thanks, Chris. I just tried, and it doesn't look like it's the
> terminal capturing Ctrl-S. I issues "Ctrl-V Ctrl-S" and didn't get the
> dialog either.

I think he’s right that the terminal captures Ctrl-S but the solution 
doesn’t work. Running the command:

    stty stop ^-

before elinks should work. With zsh it won’t work if you told it to 
freeze the tty settings somewhere in your config with “ttyctl -f”, you 
have to run “ttyctl -u” first.

With zsh you can also use:

    STTY="stop ^-" elinks

it changes the settings only for the command and resets them when it 
finishes instead of modifying them for the whole terminal. It works also 
if you have “ttyctl -f” in your config.

> I should mention another issue I saw, where making changes to the
> elinks.conf file did not apply in the application as I subsequently
> launched it. The only way to apply those changes was to launch "Setup
> -> Options Manager", then apply the changes there, and exit.
> 
> This is the first keybindings change I've tried, perhaps there is a
> similar problem with it?

It should have worked, maybe there was already an instance of ELinks 
running and the new instance connected to it?



More information about the elinks-users mailing list