[elinks-users] Trying to compile ELinks with Lua support

John Magolske listmail at b79.net
Tue Aug 19 08:38:59 PDT 2014


* John Magolske <listmail at b79.net> [140818 00:43]:
> I'm trying to compile elinks-0.12-20140816 with lua support:
> [...]
> This is on Debian Sid, and I do have liblua5.1-0-dev installed.

I see the problem now -- only version 5.0 of Lua is supported:

http://elinks.or.cz/documentation/html/manual.html-chunked/ch14s02.html
http://bugzilla.elinks.cz/show_bug.cgi?id=742

I'd installed liblua50-dev earlier, which didn't help. A closer look
revealed that liblualib50 is what's needed:

    liblua50-dev -- Main interpreter library for Lua 5.0: static
    library and headers Using this package you can develop
    applications which have Lua interpreters built into them.

    liblualib50-dev -- Extension library for Lua 5.0: static and
    headers This package allows you to link to the Lua standard
    libraries providing maths, string and IO functions to your Lua
    based programs.

Somehow liblualib50 must have been uninstalled since the last time I
compiled with Lua support. Installing this package now allows ELinks
to compile with Lua support.

Regards,

John

-- 
John Magolske
http://B79.net/contact


More information about the elinks-users mailing list