DocBook hint and Perl SGMLS module

Didier Richard didierj.richard at wanadoo.fr
Thu Sep 12 13:51:28 PDT 2002


Tushar Teredesai a écrit:
> Didier Richard wrote:
> 
>> Hi all
>>
>> I'm trying to get Gnome-2 up, so I need to get GTK2 first OK.
>> It is recommended in the BLFS book to use the DocBook hint by Tush to 
>> get SGML docs OK. I installed first parts OK, but when it comes to 
>> "docbook-utils" I get :
>>
>> Making all in man
>> make[2]: Entre dans le répertoire 
>> `/usr/src/docbook/utils/docbook-utils-0.6.11/doc/man'
>> SGML_CATALOG_FILES=/etc/sgml/catalog \
>> SGML_SEARCH_PATH=../../doc:.. \
>>         nsgmls ../../doc/docbook-utils.sgml | \
>>         sgmlspl ../../helpers/docbook2man-spec.pl
>> /bin/sh: sgmlspl: command not found
>>   [snip] [lots of error messages then]
>> nsgmls:../../doc/refentry/jw.sgml:75:20:E: element "OPTION" undefined
>> make[2]: *** [jw.1] Erreur 127
>> make[2]: Quitte le répertoire 
>> `/usr/src/docbook/utils/docbook-utils-0.6.11/doc/man'
>> make[1]: *** [all-recursive] Erreur 1
>>
> I don't have SGMLS Perl module installed (unless it is a part of Perl 
> 5.8.0). Are you installing in the same order as the hint? Are you sure 
> you did not forget one of the install-catalog steps? I had a similar 
> error when installing docbook-utils. Turned out to be a missed command. 
> Also check the permissions on the files in /etc/sgml.
> 

First, thanks for answering so quick.

About the SGMLS Perl module, it looks like an old stuff, (release 1.03 I 
installed is dated december 1995), now it's installed but it doesn't 
change much.

I have re-done all the hint step by step.
All "make install" are been re-done.
All comand-line have been cut'n'pasted.
Each time, when it comes to an "install-catalog" I get this kind of 
complains :

Warning: /usr/share/sgml/docbook/dsssl-stylesheets-1.77/catalog is 
already installed in the centralized catalog /etc/sgml/

I have put /etc/sgml 'world-writable'.

To no end :
  cannot generate system identifier for public text "-//OASIS//DTD 
DocBook V3.1//EN"
when I do a "make" in docbook-utils.

Just a (maybe) stupid question :
The hint says "docbook-sgml-dtd (3.1 & 4.1)"

Do I need _both_ 3.1 and 4.1 releases ?
I installed only 4.1 ...

Didier

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe hints' in the subject header of the message



More information about the hints mailing list