crosscompiling-x86 problems [and fixes]

conathan at conet.dyndns.org conathan at conet.dyndns.org
Sat Jul 12 15:46:36 PDT 2003


>> I have been working on perfecting my selfbuilt LFS build script.
>> [perfect
>> for me, I have a hunch some people would hate what I did].  I decided to
>> incorperate the crosscompiling hint, as I have a 386 I wanted to setup
>> [not quite sure why I want to do this, but...]
> Interested, can you send me a copy?

What do you want to do with it? [test out the cross-compile stuff?].

I did some minor editing,

GCC 2.95.3, the last thing I tried was to get it into /usr.  [failed, I
guess libstdc++.5 wasn't found, when I hit groff] (so I just threw it back
to /opt/gcc-2.95.3

I have a cygwin, and mingw32 cross compiler [experimenting with it, no
clue if they work].  cygwin's wont work, unless your host has the libs
(got precompiled libs for mingw32, so that works), but since you probably
dont want these, I stuck a exit 0 on their scripts.

I also have nasm.  [I like nasm], not sure if I updated lilo or not. 
[LFS's lilo boots, that's usually enough for me]

I deleted all the packages, and stuck a readme.txt with all the files you
have to find.  [probably easier to run some sed to change .gz to .bz2, and
dump your collection of files in there].  (You can leave out what you dont
want [ex:/ mingw and cygwin junk]  just edit the scripts accordingly.
[good old ls > readme].


ftp://conet.dyndns.org/script.tar.bz2

also, the configuration information is within lfs.5.sh/profile.  [stuff
like LFS, and LFSCHECK (if it does make check or not)].

(BTW, this is bad, but I run it as root.  you can probably fix it to do
otherwise, if you like  [just edit lfs.sh and see what it does]).

ONE LAST THING.  I stuck that --build=i386-pc-linux-gnu [or build=$CHOST]
onto glibc only.  [the others compiled, I never bothered to see if they
were missing bits].



-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe hints' in the subject header of the message



More information about the hints mailing list