Xorg -configure Duplicate symbol (6.8.2)

Declan Moriarty junk_mail at iol.ie
Mon Feb 27 09:26:58 PST 2006

Recently, Somebody Somewhere wrote these words
> I compiled Xorg 6.8.2 sucessfully, but when I run Xorg -configure I get the 
> following output.
> /*************/
> Current Operating System: Linux HLFS #17 PREEMPT Sun Feb 26 
> 17:42:13 CET 2006 i686
> Build Date: 25 February 2006
>        Before reporting problems, check http://wiki.X.Org
>        to make sure that you have the latest version.
> Module Loader present
> Markers: (--) probed, (**) from config file, (==) default setting,
>        (++) from command line, (!!) notice, (II) informational,
>        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 27 16:11:30 2006
> Duplicate symbol __i686.get_pc_thunk.bx in 
> /usr/X11R6/lib/modules/fonts/libbitmap.a:bitmapmod.o
> Also defined in /usr/X11R6/lib/modules/fonts/libbitmap.a
> Fatal server error:
> Module load failure
> Please consult the The X.Org Foundation support
>         at http://wiki.X.Org
> for help.
> Please also check the log file at "/var/log/Xorg.0.log" for additional 
> information.
> /*************/
> Dmesg doesn't hold anymore info about the error. I read around and 
> understand that this has something to do with the X module loader.
> Therefore I expected an issue with this flag in the host.def file.
> #define MakeDllModules    YES
> I have tried building with and without it, but that didn't help.
> Building  Hardened Linux From Scratch - Version SVN-20060122.
> Other than X, everything seems to be fine.
> I'd appreciate a few suggestions.

Open the tarball and go again. I suspect a typo. Or you could try
Xorg-6.9.0 according to the instructions I posted or xorg-7.0.0
with Kevin Day's script.

The issue is that dlloader has problems with hardened systems
which link with -z now, and some one of the commands alter that on
a big heap of Makefiles. It needs the -nonow switch, which doesn't 
go handily into X.

I got different behaviour from one of the sed commands here doing
this. The obvious symptom was that sometimes it took 2 seconds to
return a prompt, and sometines returned it immediately

I suspect mouse or screen type issues. The screen size hops
all over the place when you're going from console to X and I have
seen screen width and length strangeness interfere with things here.
The console programs lose track of the current screen size. So the
mouse can only navigate the top half of the screen, or 20 spaces
are included (Or 20 characters left out) when you copy & paste 2

I got a solution on list for Xorg-6.9 which is to alter the gcc specs
file (default switches). X uses gcc for linking. The specs negate 
-nonow, and inserts -z now. I now have specs.orig, and
specs.softlink in the directory
/usr/lib/gcc/i686-pc-linux-gnu/3.4.4/ and copy them in as
appropiate. The specs.softlink leaves the linking at -nonow.

	With best Regards,

	Declan Moriarty.

More information about the hlfs-dev mailing list