lfscmd - WARNING: could not find a value for glibc-version

Mark Hymers markh at linuxfromscratch.org
Tue Dec 31 18:13:42 PST 2002


On Wed, 01, Jan, 2003 at 12:40:57PM +1100, Greg Schafer spoke thus..
> But seriously, lightning fast now. No errors. Only suggestion I could make
> is to setup the configury to find libxml2 and error out otherwise (should be
> plenty of examples out there to copy from).

There's probably a much better way to do it but I found this in the
scrollkeeper sources:

dnl ====================================
dnl = Begin tests for libxml2
dnl ====================================
AC_PATH_PROG(XML_CONFIG,xml2-config,no)
if test x$XML_CONFIG = xno; then
  AC_MSG_ERROR(Couldn't find xml2-config please install the libxml2 and
libxml2-devel packages)
fi
AC_MSG_CHECKING(libxml2 version)
libxml2_version=`$XML_CONFIG --version | awk '{print $1;}'`
AC_MSG_RESULT($libxml2_version)
libxml2_version=`echo $libxml2_version | awk -F. '{print $1 * 10000 + $2
* 100 + $3;}'`
if test 0$libxml2_version -lt 20419; then
        AC_MSG_ERROR(libxml2 2.4.19 or later required)
fi
XML_LIBS=`$XML_CONFIG --libs`
XML_CFLAGS=`$XML_CONFIG --cflags`
AC_SUBST(XML_LIBS)
AC_SUBST(XML_CFLAGS)
LIBXML2_REQUIRED=2.4.19
AC_SUBST(LIBXML2_REQUIRED)
dnl ====================================
dnl = End tests for libxml2
dnl ====================================

I added it just before AC_OUTPUT(Makefile)
and it seems to work.

Mark

-- 
Mark Hymers <markh at linuxfromscratch dot org>

"I got off at Durham... and fell in love with it instantly.  Why, it's 
 wonderful - a perfect little city.  If you have never been to Durham, go 
 there at once. Take my car. It's wonderful."
     Notes from a Small Island, Bill Bryson
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-book' in the subject header of the message



More information about the lfs-book mailing list