[Bug 463] New: /etc/mtab should not be a symlink

bugzilla at linuxfromscratch.org bugzilla at linuxfromscratch.org
Wed Jan 8 02:45:36 PST 2003


http://bugs.linuxfromscratch.org/show_bug.cgi?id=463

           Summary: /etc/mtab should not be a symlink
           Product: Linux From Scratch
           Version: 3.3
          Platform: All
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: major
          Priority: P2
         Component: Book
        AssignedTo: lfs-book at linuxfromscratch.org
        ReportedBy: magius at warpdgfx.com
         QAContact: lfs-book at linuxfromscratch.org


/etc/mtab is currently being symlinked to /proc/mounts.  This causes problems with 
applications that watch mtab. 
 
KDE for example loses performance becuase it will continually report that the 
/etc/mtab file is a dirty file.  Once I changed the file to a static file in /etc it worked 
much better and KDE stopped complaining. 
 
Is there a possibility this could be changed in future version of LFS?  The KDE 
Mailing list repeated gets complaints on this.  Below I've attached one of the emails 
I received from the KDE Devel team regarding this problem. 
 
---<SNIP>--- 
> ------- Additional Comments From jowenn at kde.org  2003-01-05 19:14 ------- 
> As long as LFS, doesn't use a real MTAB, but a link to /proc/mounts I see 
> no real way to fix that. I've tried to do my best, to reduce the 
> performance problem, but since proc doesn't know about mtime :( 
> 
> What you can do is disable the devices:/ view on kdesktop in the desktop 
> settings and edit in $(KDEPREFIX)/share/services/kded/mountwatcher.desktop 
> the line X-KDE-Kded-autoload=true 
> to look like 
> X-KDE-Kded-autoload=false 
 
I don't think about /etc/mtab being a symlink.  Actually it was quite easy to  
fix once you pointed me to the symlink. 
 
I dropped to single user mode (ie. telinit 1) 
 
Killed any othe processes not killed by init so that all I had running was my  
single bash shell as root. 
 
umounted all unneeded filesystems. 
 
Deleted symlink in /etc and touched an empty file. 
 
Just to test it, I mounted another filesystem and it wrote to the static file. 
 
Then in /etc/rc.d/init.d/mountfs  I changed: 
 
mount -n -o remount,rw / 
 
to 
 
mount -o remount,rw / 
 
And all works fine :) 
 
---<SNIP>---   
 
Regards, 
Adam Watson



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
You are the QA contact for the bug, or are watching the QA contact.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-book' in the subject header of the message



More information about the lfs-book mailing list