[LFS Trac] #1724: GCC 4.1.0

LFS Trac trac at linuxfromscratch.org
Thu Mar 16 06:16:58 PST 2006


#1724: GCC 4.1.0
----------------------------------------+-----------------------------------
 Reporter:  chris at linuxfromscratch.org  |        Owner:  lfs-book at linuxfromscratch.org
     Type:  enhancement                 |       Status:  new                          
 Priority:  normal                      |    Milestone:                               
Component:  Book                        |      Version:  SVN                          
 Severity:  normal                      |   Resolution:                               
 Keywords:                              |  
----------------------------------------+-----------------------------------
Comment (by martyman99999 at yahoo.com):

 http://kerneltrap.org/node/6271 also discusses the Java failure.
 http://gcc.gnu.org/gcc-4.1/changes.html discusses changes to the ABI and
 memory model.

 Note a recent tar is required but already in the book.
 Note a more recent binutils 2.16.91 is required but not already in the
 book.

 I do not fully understand the implications of the memory model change on
 attempting to run precompiled code (e.g. Nvidia closed source driver).
 However because of this change I encourage treading very carefully into
 4.1.0.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/lfs/ticket/1724>
LFS Trac <http://wiki.linuxfromscratch.org/lfs/>
Linux From Scratch: Your Distro, Your Rules.



More information about the lfs-book mailing list