[LFS Trac] #1720: On 2.6.15.4/UDEV085, swapon sometimes fails

LFS Trac trac at linuxfromscratch.org
Mon Mar 20 13:28:36 PST 2006


#1720: On 2.6.15.4/UDEV085, swapon sometimes fails
-------------------------------------+--------------------------------------
 Reporter:  martyman99999 at yahoo.com  |        Owner:  matthew at linuxfromscratch.org
     Type:  defect                   |       Status:  assigned                    
 Priority:  normal                   |    Milestone:                              
Component:  Bootscripts              |      Version:  udev_update                 
 Severity:  blocker                  |   Resolution:                              
 Keywords:                           |  
-------------------------------------+--------------------------------------
Comment (by archaic at linuxfromscratch.org):

 For more than a week now, with udev-087, linux-2.6.15.6, and with the
 modified code that added the "confirm" tests, but without the latest "echo
 -en '*'" change, there has not been a bugreport. I have tested with every
 iteration of the following devices: external HD, USB mouse, USB keyboard,
 PTP2 camera (not mass storage). The same setup as this produced sporadic
 bugreports with udev-086.

 Alex, please advise what further testing you want me to do. Should I
 revert udev or add the "echo -en '*'" snippet, or anything like that? And
 is anyone else testing this?

 Matt, you were getting bugreports, too. What about with the newer kernel
 and udev? Are you still getting them? I will try a new build using the new
 udev_update bootscripts and report back. I also have a thumbdrive I can
 add to the mix. If I get a chance, I might even have time to throw a spare
 SCSI array into my gateway and kick off a build on that to test SCSI
 devices, but no promises at this point.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/lfs/ticket/1720>
LFS Trac <http://wiki.linuxfromscratch.org/lfs/>
Linux From Scratch: Your Distro, Your Rules.



More information about the lfs-book mailing list