[LFS Trac] #2883: Glibc-2.14

Matthew Burgess matthew at linuxfromscratch.org
Tue Aug 9 06:43:56 PDT 2011


On Tue, 09 Aug 2011 14:53:08 +0200, Tobias Gasser <lfs at ebp-gasser.ch> wrote:
> 
>> Yes, Sun RPC was removed from the Glibc tarball.  It's now recommended
>> to use the TI-RPC library
>> (http://sourceforge.net/projects/libtirpc/files/libtirpc/).
> 
> 
> thanks for your advice!
> 
> but libtirpc 0.2.2 does not build with glibc 2.14!!
> 
> i get the same error as mentionned in
> 
> http://sourceforge.net/tracker/index.php?func=detail&aid=3311050&group_id=183075&atid=903784

Ouch!  There's a workaround that worked for me which is to copy
rpcsvc/{nis,nis_tags,nislib}.h from the glibc-2.14 source tarball into /usr/include/rpcsvc.

Well, by 'worked for me', it finished the 'make' invocation.  I've not bothered installing
or trying to use libtirpc though.  It'd be interesting if you could find out whether glibc
or libtirpc should be providing those headers!

Thanks,

Matt.




More information about the lfs-book mailing list