[LFS Trac] #2883: Glibc-2.14

Bruce Dubbs bruce.dubbs at gmail.com
Thu Aug 11 08:02:38 PDT 2011


Tobias Gasser wrote:
> Matthew Burgess schrieb:
> p://sourceforge.net/tracker/index.php?func=detail&aid=3311050&group_id=183075&atid=903784
>> Ouch!  There's a workaround that worked for me which is to copy
>> rpcsvc/{nis,nis_tags,nislib}.h from the glibc-2.14 source tarball into /usr/include/rpcsvc.
>>
>> Well, by 'worked for me', it finished the 'make' invocation.  I've not bothered installing
>> or trying to use libtirpc though.  It'd be interesting if you could find out whether glibc
>> or libtirpc should be providing those headers!
> 
> the following worked for me
> 
> after unpacking i use the following:
> 
> mkdir -p /usr/include/rpc{,svc}
> cp sunrpc/rpc/*.h /usr/include/rpc
> cp sunrpc/rpcsvr/*.h /usr/include/rpcsvc
> cp nis/rpcsvc/*.h /usr/include/rpcsvc
> 
> install seems to overwrite some of those files, thus i do the copy just
> after unpacking.
> 
> now i am able to build libtirpc after zlib (i'm not shure whether zlib
> is used by libtirpc, but this works for me) and linuxpam compiles fine.
> 
> now the big BUT:
> 
> i can't build xinetd, fuse and lsof.
> 
> building the system with glibc 2.13 without libtirpc all build without
> problem.
> 
> i'll now start to build Xorg and XFCE to check for other incompatibilities.
> 
> as soon as i have the results i'll post them.

I think this should really be in blfs-dev.

   -- Bruce




More information about the lfs-book mailing list