Ch5 GCC pass 1 failure & Prerequisites (Part 2)

Test Man mr_nobby at yahoo.com
Sun Feb 13 05:26:08 PST 2011


Hello lfs-book.

Last year when I suffered the following failure:

"checking for library containing strerror... configure: error: Link tests are not allowed after GCC_NO_EXECUTABLES",

I posted here: http://www.mail-archive.com/lfs-book@linuxfromscratch.org/msg13114.html about this, regarding possible changes to the way GCC was built or prerequisites needed to be revised, which in turn was based on the solution here: From http://www.mail-archive.com/lfs-book@linuxfromscratch.org/msg12674.html

It was suggested that my hardware was too old and I should be running newer hardware and a newer host system. Well it appears since then the prerequisites have been revised, but despite this and despite the fact I am building on an i686 x86 system, I have the same error.
Do the prerequisites need updating again I wonder? Or perhaps the build process needs to be re-examined?

My version-check.sh output FYI:

$ bash version-check.sh
bash, version 4.0.28(2)-release
/bin/sh -> /bin/bash
Binutils: (GNU Binutils) 2.19.1
bison (GNU Bison) 2.4.1
/usr/bin/yacc -> /usr/bin/yacc
bzip2,  Version 1.0.5, 10-Dec-2007.
Coreutils:  7.5
diff (GNU diffutils) 2.8.1
find (GNU findutils) 4.4.2
GNU Awk 3.1.7
/usr/bin/awk -> /usr/bin/gawk
gcc (GCC) 4.4.1
GNU C Library stable release version 2.10.1
GNU grep 2.5.4
gzip 1.3.12
Linux version 2.6.37 (xxxxx at xxxxxxx) (gcc version 4.4.1 (GCC) ) #1 Sat Feb 12 06:26:21 GMT 2011
m4 (GNU M4) 1.4.13
GNU Make 3.81
patch 2.5.9
Perl version='5.10.1';
GNU sed version 4.2.1
tar (GNU tar) 1.22
Texinfo: makeinfo (GNU texinfo) 4.13
Compilation OK

Once again, the original solution:

"make all-gcc all-target-libgcc" instead of "make"
"make install-gcc install-target-libgcc" instead of "make install"

has worked for me and allowed me to continue with Ch5.

Is it really the prerequsites that are at fault here? It seems they might not be; it's certainly not the hardware, and it's nothing to do with CFLAGS.


      



More information about the lfs-book mailing list