Ch5 GCC pass 1 failure & Prerequisites (Part 2)

Gilles Espinasse g.esp at free.fr
Sun Feb 13 05:57:28 PST 2011


----- Original Message ----- 
From: "Test Man" <mr_nobby at yahoo.com>
To: <lfs-book at linuxfromscratch.org>
Sent: Sunday, February 13, 2011 2:26 PM
Subject: Ch5 GCC pass 1 failure & Prerequisites (Part 2)


> Hello lfs-book.
>
> Last year when I suffered the following failure:
>
> "checking for library containing strerror... configure: error: Link tests
are not allowed after GCC_NO_EXECUTABLES",
>
> I posted here:
http://www.mail-archive.com/lfs-book@linuxfromscratch.org/msg13114.html
about this, regarding possible changes to the way GCC was built or
prerequisites needed to be revised, which in turn was based on the solution
here: From
http://www.mail-archive.com/lfs-book@linuxfromscratch.org/msg12674.html
>
I found someone more masochistic than me trying to compile on PI-166.
Anyway, that should not be the real issue until you have enought memory to
compile.
This is really slow and gcc may take a very long time to compile but that
should work.
I have compiled from a PI laptop (but not since 2 or 3 years).

> It was suggested that my hardware was too old and I should be running
newer hardware and a newer host system. Well it appears since then the
prerequisites have been revised, but despite this and despite the fact I am
building on an i686 x86 system, I have the same error.
> Do the prerequisites need updating again I wonder? Or perhaps the build
process needs to be re-examined?
>
> Once again, the original solution:
>
> "make all-gcc all-target-libgcc" instead of "make"
> "make install-gcc install-target-libgcc" instead of "make install"
>
> has worked for me and allowed me to continue with Ch5.
>
> Is it really the prerequsites that are at fault here? It seems they might
not be; it's certainly not the hardware, and it's nothing to do with CFLAGS.

Are you really certain about CFLAGS when you write this has nothing to do?

Beware not to set CFLAGS on chap5
It really depend how you set CFLAGS, if you export CFLAGS or use it in each
command line.
This is really tricky :
CFLAGS="-O2 -pipe" make
does not behave the same in sub-makefiles as
make CFLAGS="-O2 -pipe"
On the first case, only the top makefile use CFLAGS value, on the second
case, sub makefiles inherit CFLAGS. Sometime, makefile inherit the CFLAGS
existing at configure time.

I am building (not exactly lfs-book) on older host centos-5.5 based
(bash-3.2.25, gcc-4.1.2, glibc-2.5) than yours and I doubt the reason you
put in front is the right. I am using a different ./configure for gcc but
still use the same make && make install and that simply work.

Gilles




More information about the lfs-book mailing list