[lfs-book] [LFS Trac] #3104: no perl-5.16.0-libc-1.patch and perl-5.16.0 can't be built in toolchain

LFS Trac trac at linuxfromscratch.org
Thu May 31 04:01:54 PDT 2012


#3104: no perl-5.16.0-libc-1.patch and perl-5.16.0 can't be built in toolchain
--------------------+-------------------------------------------------------
 Reporter:  xinglp  |       Owner:  lfs-book@…                   
     Type:  task    |      Status:  new                          
 Priority:  normal  |   Milestone:  7.2                          
Component:  Book    |     Version:  SVN                          
 Severity:  normal  |    Keywords:                               
--------------------+-------------------------------------------------------

Comment(by matthew@…):

 Replying to [comment:3 xinglp]:
 > Finally, I install gdbm before perl to make it work.

 Well, that's obviously not the right thing to do (I appreciate it got it
 to work for you, but it shouldn't be necessary).  It looks like your Perl
 build is picking up GDBM headers/libs from your host but then when it
 tries to compile/link against them in the configure stage, it can't find
 them again (presumably because the perl libc patch changes have come into
 effect at that point).

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/lfs/ticket/3104#comment:4>
LFS Trac <http://wiki.linuxfromscratch.org/lfs/>
Linux From Scratch: Your Distro, Your Rules.



More information about the lfs-book mailing list