[lfs-book] r10327 - in trunk/BOOK: . bootscripts bootscripts/lfs/sysconfig chapter01 chapter05 chapter06 prologue

bdubbs at higgs.linuxfromscratch.org bdubbs at higgs.linuxfromscratch.org
Thu Aug 22 07:45:43 PDT 2013


Author: bdubbs
Date: Thu Aug 22 07:45:43 2013
New Revision: 10327

Log:
Update minimum kernel requirement for the host
Minor edit in rc.sit requiring bootscript update.

Modified:
   trunk/BOOK/bootscripts/ChangeLog
   trunk/BOOK/bootscripts/lfs/sysconfig/rc.site
   trunk/BOOK/chapter01/changelog.xml
   trunk/BOOK/chapter05/glibc.xml
   trunk/BOOK/chapter06/glibc.xml
   trunk/BOOK/general.ent
   trunk/BOOK/packages.ent
   trunk/BOOK/prologue/hostreqs.xml

Modified: trunk/BOOK/bootscripts/ChangeLog
==============================================================================
--- trunk/BOOK/bootscripts/ChangeLog	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/bootscripts/ChangeLog	Thu Aug 22 07:45:43 2013	(r10327)
@@ -1,3 +1,6 @@
+2013-08-21 Bruce Dubbs <bdubbs at linuxfromscratch.org>
+   * Delete duplicate entry in rc.site file.
+
 2013-08-05 Bruce Dubbs <bdubbs at linuxfromscratch.org>
    * Use STATIC_GATEWAY for ipv4-static-route purposes
 

Modified: trunk/BOOK/bootscripts/lfs/sysconfig/rc.site
==============================================================================
--- trunk/BOOK/bootscripts/lfs/sysconfig/rc.site	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/bootscripts/lfs/sysconfig/rc.site	Thu Aug 22 07:45:43 2013	(r10327)
@@ -50,9 +50,6 @@
 # Skip reading from the console
 #HEADLESS=yes
 
-# Speed up boot without waiting for settle in udev_retry
-#OMIT_UDEV_RETRY_SETTLE=yes
-
 # Write out fsck progress if yes
 #VERBOSE_FSCK=no
 

Modified: trunk/BOOK/chapter01/changelog.xml
==============================================================================
--- trunk/BOOK/chapter01/changelog.xml	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/chapter01/changelog.xml	Thu Aug 22 07:45:43 2013	(r10327)
@@ -36,6 +36,16 @@
     </listitem>
 -->
     <listitem>
+      <para>2013-08-22</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Update the minimum kernel requirement to 
+          2.6.34 in host system requirements.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>2013-08-21</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/chapter05/glibc.xml
==============================================================================
--- trunk/BOOK/chapter05/glibc.xml	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/chapter05/glibc.xml	Thu Aug 22 07:45:43 2013	(r10327)
@@ -80,7 +80,7 @@
       --host=$LFS_TGT                               \
       --build=$(../glibc-&glibc-version;/scripts/config.guess) \
       --disable-profile                             \
-      --enable-kernel=2.6.34                        \
+      --enable-kernel=&min-kernel;                        \
       --with-headers=/tools/include                 \
       libc_cv_forced_unwind=yes                     \
       libc_cv_ctors_header=yes                      \

Modified: trunk/BOOK/chapter06/glibc.xml
==============================================================================
--- trunk/BOOK/chapter06/glibc.xml	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/chapter06/glibc.xml	Thu Aug 22 07:45:43 2013	(r10327)
@@ -72,7 +72,7 @@
 <screen><userinput remap="configure">../glibc-&glibc-version;/configure    \
     --prefix=/usr          \
     --disable-profile      \
-    --enable-kernel=2.6.34 \
+    --enable-kernel=&min-kernel; \
     --libexecdir=/usr/lib/glibc</userinput></screen>
 
     <variablelist>

Modified: trunk/BOOK/general.ent
==============================================================================
--- trunk/BOOK/general.ent	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/general.ent	Thu Aug 22 07:45:43 2013	(r10327)
@@ -1,5 +1,5 @@
-<!ENTITY version         "SVN-20130821">
-<!ENTITY releasedate     "August 21, 2013">
+<!ENTITY version         "SVN-20130822">
+<!ENTITY releasedate     "August 22, 2013">
 <!ENTITY copyrightdate   "1999-2013"><!-- jhalfs needs a literal dash, not – -->
 <!ENTITY milestone       "7.4">
 <!ENTITY generic-version "development"> <!-- Use "development", "testing", or "x.y[-pre{x}]" -->
@@ -14,6 +14,7 @@
 <!ENTITY livecd-root     "&lfs-root;livecd/">
 <!ENTITY test-results    "&lfs-root;lfs/build-logs/&generic-version;/">
 <!ENTITY errata          "&lfs-root;lfs/errata/&generic-version;/">
+<!ENTITY min-kernel      "2.6.34">
                          
 <!ENTITY lfs-ticket-root "http://wiki.linuxfromscratch.org/lfs/ticket/">
 

Modified: trunk/BOOK/packages.ent
==============================================================================
--- trunk/BOOK/packages.ent	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/packages.ent	Thu Aug 22 07:45:43 2013	(r10327)
@@ -310,7 +310,7 @@
 <!ENTITY less-ch6-du "3.6 MB">
 <!ENTITY less-ch6-sbu "less than 0.1 SBU">
 
-<!ENTITY lfs-bootscripts-version "20130805">                 <!-- Scripts depend on this format -->
+<!ENTITY lfs-bootscripts-version "20130821">                 <!-- Scripts depend on this format -->
 <!ENTITY lfs-bootscripts-size "BOOTSCRIPTS-SIZE KB">         <!-- Updated in Makefile -->
 <!ENTITY lfs-bootscripts-url "&downloads-root;lfs-bootscripts-&lfs-bootscripts-version;.tar.bz2">
 <!ENTITY lfs-bootscripts-md5 "BOOTSCRIPTS-MD5SUM">           <!-- Updated in Makefile -->

Modified: trunk/BOOK/prologue/hostreqs.xml
==============================================================================
--- trunk/BOOK/prologue/hostreqs.xml	Wed Aug 21 13:33:31 2013	(r10326)
+++ trunk/BOOK/prologue/hostreqs.xml	Thu Aug 22 07:45:43 2013	(r10327)
@@ -81,18 +81,16 @@
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Linux Kernel-2.6.25</emphasis>
-      (having been compiled with GCC-4.1.2 or greater)</para>
+      <para><emphasis role="strong">Linux Kernel-&min-kernel;</emphasis></para>
 
       <para>The reason for the kernel version requirement is that we specify
       that version when building <application>glibc</application> in Chapter 6
       at the recommendation of the developers.  It is also required by
       udev.</para>
 
-      <para>If the host kernel is either earlier than 2.6.25, or it was not
-      compiled using a GCC-4.1.2 (or later) compiler, you will need to replace
-      the kernel with one adhering to the specifications. There are two ways
-      you can go about this. First, see if your Linux vendor provides a 2.6.25
+      <para>If the host kernel is earlier than &min-kernel; you will need to replace
+      the kernel with a more up to date version. There are two ways
+      you can go about this. First, see if your Linux vendor provides a &min-kernel;
       or later kernel package. If so, you may wish to install it. If your
       vendor doesn't offer an acceptable kernel package, or you would prefer not to
       install it, you can compile a kernel yourself. Instructions for



More information about the lfs-book mailing list