[lfs-book] [LFS Trac] #3456: Binutils does not install libiberty.a

LFS Trac trac at linuxfromscratch.org
Wed Dec 25 11:02:41 PST 2013


#3456: Binutils does not install libiberty.a
--------------------+-------------------------
 Reporter:  chris   |       Owner:  lfs-book@…
     Type:  task    |      Status:  new
 Priority:  normal  |   Milestone:  7.5
Component:  Book    |     Version:  SVN
 Severity:  normal  |  Resolution:
 Keywords:          |
--------------------+-------------------------

Comment (by ken@…):

 I *was* going to stick my head above the parapet and ask why LFS should
 care about libiberty ?  I don't recall the full details of an earlier
 thread, which was many years ago, but my conclusion was that any package
 which needs (or cares) about libiberty ought to provide its own version so
 that it doesn't get messed up by version changes. The following packages
 are known to care, and ship their own versions: binutils, gcc, gdb. And I
 felt confident in asserting that we don't need libiberty because I've not
 only built my own (relatively minimalist) desktop _without_ installing
 libiberty.a, I've also built and installed or DESTDIR installed everything
 in BLFS when testing make-4.0 a couple of months ago without needing it.

 Note the "was" at the start of that paragraph :-(  I googled trying to
 find references, and any notes on packages which require libiberty.  The
 kernel's perf subsystem requires, or has required, libiberty, e.g.
 [http://www.jethrocarr.com/2011/07/17/where-is-my-liberty/ ] .

 So I guess we ought to have it from either binutils or gcc.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/lfs/ticket/3456#comment:2>
LFS Trac <http://wiki.linuxfromscratch.org/lfs/>
Linux From Scratch: Your Distro, Your Rules.



More information about the lfs-book mailing list