Installing Bash

Gerard Beekmans gerard at linuxfromscratch.org
Wed Aug 2 09:58:47 PDT 2000


> I have been trying to build my LFS for about two weeks now and am stuck in one place.  I tried installing bash-2.04 and keep getting the "can't find -ltermcap" error message.  I have read the suggestions in the archives and tried most: trying to install ncurses and termcap on my main system, trying to install without termcap(this one is kind of tight since Mandrake 7.1 makes termcap and ncurses mandatory installs and will not let you install without them) these are just a few that I have tried.
> 
> When I tried without the -disable option, it begins but tells me that the machine is invalid or unrecognized but continues to -ltermcap.  
> 
> I am wondering if the fact that I am not doing the optimization will affect any of this.  I am sought of new and need some help.

Optimizing shouldn't affect it.

Just install the Ncurses package on your normal Linux distribution from
source, and not using your Mandrake installation tool. Unpack Ncurses
and install by:
./configure --prefix=/usr --with-shared
make
make install

That should do it. Now try to compile bash again.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list