LFS in linuxtoday.com

Tim stcroixt at softhome.net
Sun Aug 6 04:44:56 PDT 2000


Panos Maheras wrote:
> 
> From:
> 
> "The only distrobution tougher than Slackware...
> ...is the one you build yourself, like http://www.linuxfromscratch.org ... it
> can be BRUTAL!
> 
> LFS brutal??? Common!! :-)
> 
> Panos Maheras.

That badly spelled post is mine, after I ran into a block I couldn't get
around.  I've been assuming that it's a simple thing so I've kept my
mouth shut trying not to seem stupider than I am, hoping someone else
will cover it... but I can't even find it in the archives, so I might as
well bite the bullet and spill it.

>From the very first package installation I've gotten "Permission denied"
errors trying to run ./configure.  Switch to root and same thing. 
Permissions shouldn't matter when run as root, right?

I've gotten around that by unpacking the sources into my root partition
and building them there, but I didn't want to do that for the kernel as
I'm still running 2.2.13.  (No reason... I just never upgraded, never
felt the need to.)

Well, 'make depmod' ended with 'Permission denied.'  And I stopped there
and decided I had to deal with the real problem, why I can't even run
configure on packages on a mounted partition.

Here's my lfs fstab line:

/dev/hda3      /mnt/lfs   ext2    noauto,user  0 0

It's a 4 gig partition entirely below the 1024 cylinder barrier
(shouldn't matter).  After I first got the error I've always mounted it
as root and did all the steps as root.

I'm starting from a Slackware 7.0 distro with some upgrades (should be
unimportant.)

I made sure everything in $LFS/ matched my root partition (owners and
groups and permissions) and still no luck.

Help!

Tim
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list