/dev/null - permission denied - last one

Gerard Beekmans gerard at linuxfromscratch.org
Thu Aug 10 05:35:50 PDT 2000


> seems like every problem that arise with chroot
> (there was another latetly in discussion) has to
> do that the chrooted device should NEVER have
> an entry in fstab, but must be mounted by hand,
> IF you want to work with chroot.
> 
> So, if LFS is build and you are still using different
> distributions (it would be normal, at least for me,
> to add that in fstab and automount to have all
> present at startup) - if this is the case, the chroot
> will not work.
> 
> I tried to modify the entry in fstab to work with that,
> but until now did not find any clue how it must look
> like to work properly.

Again, this only seems to be true on your system:

# Begin /etc/fstab
# partition	mountpoint	type	mode		dump	fsck-order

/dev/hda8	/		ext2	defaults	1	1
/dev/hda9	/usr		ext2	defaults	1	2
/dev/hda5	/home		ext2	defaults	1	2
/dev/hda7	/usr2		ext2	defaults	1	2
/dev/hda13	/usr2/images	ext2	defaults	1	2

/dev/hda11	/mnt/lfs	ext2	defaults	1	2
/dev/hda12	/mnt/lfs/usr	ext2	defaults	1	2
<cut the rest>

as you see hda11 and 12 are the two partitions for my development LFS
system.

Have you ever tried to replace your base system's kernel with a clean
2.2.16 one?


-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list