Installing glibc-2.1.3

Jr. freemanf at cps.acast.nova.edu
Sat Aug 12 17:39:25 PDT 2000


Good evening.

I was installing glibc-2.1.3 and received this error:

running configure fragment for ../glibc-2.1.3/linuxthreads/sysdeps/unix/sysv/linux
running configure fragment for ../glibc-2.1.3/sysdeps/unix/sysv/linux
checking installed Linux kernel header files... TOO OLD!
configure: error: GNU libc requires kernel header files from
Linux 2.0.10 or later to be installed before configuring.
The kernel header files are found usually in /usr/include/asm and
/usr/include/linux; make sure these directories use files from
Linux 2.0.10 or later.  This check uses <linux/version.h>, so
make sure that file was built correctly when installing the kernel header
files.  To use kernel headers not from /usr/include/linux, use the
configure option --with-headers.

[root at localhost glibc-build]#

I don't understand why it reports my header files to be old.  I am running the
kernel 2.2.15 under Mandrake 7.1.  I installed termcap-1.3 and Ncurses-5.1 on
my normal linux system.  I have not installed the kernel on my LFS system yet
as the book (2.3.7)  has that as the next step.  

Any suggestions will be greatly appreciated.

Linuxly yours

Foyah
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list