Dependencies

John Arrowwood John.Arrowwood at merant.com
Wed Aug 23 13:29:27 PDT 2000


I am trying to install the Linux-From-Scratch using a RedHat 4.2
distribution.  I am deliberatly choosing such an old distribution so that
hopefully none of the dependencies are hidden from view.  To make matters
worse, I deliberately left out all but the most fundamentally required
packages, so that I couldn't depend on them being there.

What IS there, all of which is too old to really use: gcc, glibc, kernel
headers (2.0.30), fileutils, binutils, make
What is NOT there: bison, flex, patch

Here's what I discovered, and I hope someone can help me de-tangle this...

gcc and a number of other packages need patches, so the latest "patch"
should be installed
If possible gcc would benefit from being compiled against the latest glibc
glibc complains that my binutils aren't "versioning" so I need the latest
binutils first
Binutils won't compile without flex
flex requires bison
And here's the kicker:  The bison compile fails, with an error "ld: cannot
open -lc: no such file or directory"

So, it appears as though we have a circular dependency.  And this is all the
farther I've gotten, there may be more...  

Any ideas on how I can get Bison to compile, other than pre-installing it on
the Linux distribution?

By the way, is there a fairly complete package dependency list out there
already, or should I build one as I go?

-- John Arrowwood
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20000823/278a6d60/attachment.html>


More information about the lfs-dev mailing list