Beta (alpha?) library/ gcc probs: SOLVED!

Jason Gurtz jason at greywolftech.com
Fri Aug 25 20:44:10 PDT 2000


I guess this could maybe be considered a hint  :)

> Problem: gcc-2.95.2 will not compile during the static
> part of the installation when using a base system using
> glibc-2.1.91

The only thing I could find was a single post on a (to me)obscure news
group:

> On 8/5/2000 Graham Murry did post to mlist.linux.gcc:

> Subject: glibc 2.1.92 - gcc 2.95.2 will not build

> Following the 'hints' in the glibc documentation, I tried rebuilding
> gcc after installing glibc 2.1.92. This failed during the compilation
> of indstream.cc.
>
> This contains methods which return a value of streampos.  This is
> typedef'd to either _IO_fpos64_t or _IO_fpos_t (depending on 64 bit
> file offsets). This is further defined to map to _G_fpos64_t or
> _G_fpos_t. Under glibc 2.1.3, these were defined (via other #defines
> and typdefs) as integer types.  With glibc 2.1.92, the _G_fpos type is
> defined as a structure - which causes the compilation to fail.
>
> Is gcc 2.95.2 supposed to be able to compiled with glibc 2.1.92, or
> is a gcc 2.96 snapshot necessary?

There was never a reply, but i grabed the latest snapshot of EGCS (AUG 21,
2000 )After a longer than normal build (> 2 hours on P5-166MMX 128MB!) i had
a working compiler.  This build was able to dynamicly compile the release
library and compiler for LFS and up to now seems to be working fine.

BTW, is anyone familiar with what the mlist.linux.gcc newgroup is.  My new
ISP (DSL provider) does not carry the group on their news server.  I'm
assuming from the name it is gatewayed to a ML, but I bloody couldn't find
this post any where even after extensive searching on google and raging
search.

cheers,

~Jason






More information about the lfs-dev mailing list