Building glibc-2.1.3

Markus Wutzke wutzkem at gmx.de
Fri Dec 1 10:01:12 PST 2000


Hello,

i`m just building glibc-2.1.3 in chapter 5.
My installation distribution is SuSE 6.3.

After i started building with 
cd $LFS/usr/src/glibc-build &&     CC=/usr/local/gcc2952/bin/gcc
.../glibc-2.1.3/configure --prefix=/usr
--enable-add-ons --with-headers=/lfs/usr/include &&
make &&
make install_root=/lfs/lfs/glibc-2.1.3 install &&
make install_root=/lfs/lfs/glibc-2.1.3 localedata/install-locales

($LFS = /lfs/lfs/glibc-2.1.3 is where i want to have all the files
installed. Afterwards i mike symbolic links to the directories /lib,
/usr/lib, ... )

configure complains with following message: 

checking for msgfmt... no
checking for gmsgfmt... no
checking for makeinfo... no
configure: warning: 
*** An auxiliary program is missing or too old;
*** some features will be disabled.
*** Check the INSTALL file for required versions.

Is this normal ? 

I`ve got pt_chown in /usr/lib and /usr/libexec, both are setuid, like it
is described in INSTALL.

pt_chown --version is:
pt_chown (GNU libc) 2.1.2

Is the warning a problem ? 
Or can I just ignore it. 

Thanks,
Markus


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list