Unreal Tournament, libesd, agpgart

jdj at darkside.dynup.net jdj at darkside.dynup.net
Thu Dec 7 12:05:22 PST 2000


Sounds like you could use #nvidia on irc.openprojects.com.

They've got a the latest drivers (usually before nvidia posts them on
their site), a script to "check" the installation (warns about the files
you mention that have to be removed/renamed), agpgart backports (from 2.4
to 2.2), and lots of other goodies, not to mention a patch for the
NVdriver module to compile against 2.4.0-test10 & 11.

Jeremy

On Thu, Dec 07, 2000 at 11:53:06AM -0800, Eric A. Ayer wrote:
> I have been trying to get Unreal Tournament to run under LFS for a good while,
> and two nights ago, finally succeeded.  I am using an NVidia-based card, with
> the NVidia drivers for it.  I want to breifly describe the process, and then
> presentthe problems I'm still having.
> 
> The darn thing would not run forever.  I finally got a strace file (6 megs of
> text :) and figured out that DGA was not enabled.  After screwing around with
> that for a while, I found that there is a line in XF86Config that tells X not
> to load it.  I commented that line out.
> 
> It still didn't run.  The next thing I found was that there was a file in
> /usr/X11R6/lib/modules/extensions called libGL.a.  After kicking its ass, UT
> finally loaded.  It ran badly - it would go for 1/2 a second to several
> seconds and the freeze for an amount of time between 1/2 a second and a minute
> or so.
> 
> Finally I went back through and reinstalled all of X and the driver, paying
> close attention to the driver instructions as found on Tom's Hardware Page.
> There are a bunch of files in /usr/X11R6/lib/modules/extensions, /usr/X11R6/
> lib, and /usr/lib that are GL libs.  It says they come with Mesa3D, but they
> are installed by X and they need to die.  After deleting them and installing
> the glx portion of the driver, UT ran fairly well, at least on the first level
> which is rather small.  Even with 128MB of RAM, it had problems in the second
> level, which is a bit larger.
> 
> One possible reason is that I don't have AGPGart installed anywhere.  It isn't
> part of the 2.2.17 kernel as far as I can tell, and I haven't gone back to
> 2.2.16 yet, which has it in character devices.  I saw somehting about AGPGart
> somewhere in a library last night, and I'll try to find it, but if anyone has
> experience with it, please let me know.
> 
> 
> I also haven't run "top" on a X term on another computer while UT is running.
> It could possibly tell me if I am indeed running out of memory, but I still
> feel like it should run ok as my system is (dual 550MHz celeron, so no problem
> there).
> 
> The last really weird problem that I'm having is that the sound doesn't work.
> I am sure that this is not an UT problem, but one in the drivers, specifically
> with libesd (enlightenment sound daemon).  UT runs if Gnome has not been
> loaded to a point: it hangs at one of the menus for starting a tournament -
> but it does have sound working.  If, however, I do load Gnome, no sound works
> at all.  I can't even cat a sound file (.wav) to /dev/dsp without an error
> that the device is busy.  The major difference here is that Gnome loads esd.
> If I try to play sounds from Gnome, using the sound-event manager, those don't
> play either.  My conclusion is that esd is not installed correctly.  I
> followed the hint for installing Gnome on the LFS-hints page.
> 
> In a previous incarnation - one where UT was running badly, but running at
> all - the sound worked without any problems.  UT made sound run either with or
> without Gnome, and the sound-event manager could play sounds.  I could cat
> .wav files to /dev/dsp with Gnome loaded and it worked.  Lastly, UT could run
> (badly) with or without Gnome (incidently, I would execute xinit from the bash
> prompt and then load twm to avoid Gnome).  So I don't know what I did that
> time to get it to work, but I wish I could do it again <:)
> 
> So anyways, if someone has a clue as to why esd is not working, please tell me
> and I'll try to fix it.  At some point I plan to try to get UT running with a
> Voodoo3 card, which has a completely different set of drivers it uses, so if
> people are interested, I'll post my results.
> 
> 					-Erik
> 
> 
> -- 
> Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
> and put unsubscribe in the subject header of the message
> 

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list