possible solution for: 'can not guess host type' problem

ced hcedric at imaginet.fr
Thu Dec 7 19:12:31 PST 2000


Hi,

I ran into a problem, and I didn't find help in
the archives (there were replies to some messages, but
none of the solutions worked for me). I resolved my
problem, I submit my solution there.

When I tried to install the 'Patch' program in the 'Chapter 6'
I had a problem with the configure script:
   # ./configure --prefix=/usr
It displayed a.. nice message:
   checking host system type... configure: error: can not guess host type;
   you must specify one

Setting the hosttype manually was working:
  # ./configure --prefix=/usr --host=i586-pc-linux-gnu

So with my very little knowledge I tracked down this configure file, then
the config.guess to finally find I had no 'cc' binary ! glups :)

I forgot to follow the "Creating necessary symlinks" part
in the "Installing GCC on the LFS system" section:
http://www.linuxfromscratch.org/view/intel-2.4.3/ch05-gcc.html

See you,

-- 
ced



-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list