Network software problem..

StrandedInLodi at aol.com StrandedInLodi at aol.com
Fri Dec 8 01:49:59 PST 2000


In a message dated 12/8/00 3:28:05 AM Eastern Standard Time, 
ghovs at ghovs.moo.ca writes:

<< Hm, what do you get out of `route -n` and `ifconfig`?
 
 have you run `ifconfig eth0 IP_OF_ETH0 netmask NETMASK_OF_ETH0` and 
 `route add default gw IP_OF_YOUR_GATEWAY`?
 
 Are you sure you don't need DHCPcd?
 
 To fix the (none) thing, run /sbin/hostname -f /etc/hostname after making an 
 /etc/hostname containing, surprisingly, your desired hostname on a single 
 line. >>

I ran ifconfig, results are posted below:

eth0      Link encap:Ethernet  HWaddr 00:20:78:1A:93:DB            inet 
addr:192.168.0.0  Bcast:192.168.0.255  Mask:255.255.0.0          UP BROADCAST 
RUNNING MULTICAST  MTU:1500  Metric:1          RX packets:262 errors:0 
dropped:0 overruns:0 frame:0          TX packets:0 errors:0 dropped:0 
overruns:0 carrier:0          collisions:0 txqueuelen:100           
Interrupt:10 Base address:0xef80 

Then I ran route -n...,

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.0.0           U        0      0       
 0 eth0

I ran ifconfig eth0 192.168.0.0 netmask 255.255.0.0, but when it came to 
running the second command I did not know what to put in for the gateway. 

As far as the "/sbin/hostname -f /etc/hostname" command you offered, do you 
mean "/bin/hostname -f /etc/hostname", cause my hostname file is in the bin 
directory not the sbin directory.

Thanks for all the help,

Stranded in Good ole Lodi

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list