LILO Fatal error

Ghovs ghovs at ghovs.moo.ca
Sat Dec 9 11:04:49 PST 2000


Hey,

Try taking out the 2nd 'read-only'

It's the only thing I can think of that might cause a mess.

rgds,
Peter de Freitas

On Saturday 09 December 2000 18:11, you wrote:
> Howdy!!
> I have got a little problem with LILO.
> I compiled and installed it as described
> in the LFS-Book, but I made some changes in
> the lilo.conf by my own. I dont want to use
> a boot-partition in between the first 1023
> cylinders like SuSE 7.0 does. So I added the
> entry "lba32" to lilo.conf. Now it should be
> possible to boot from my LFS-Partition (/dev/hda3),
> but when I run lilo I get following message:
> FATAL: Empty map section
> I read the lilo and lilo.conf manual, but I
> didnt get any further. Also the Readmes in
> the LILO directory couldnt help me.
> I hope YOU can help me.
> Thanks for any help!
>
> Further information:
> -I dont have forgotten to copy the System.map
>  into /boot
> -My BIOS is only half an year old, so it should
>  support lba32
> -My harddisk is a Quantum Fireball EX12.7A
> -I use Linux from Scratch 2.4.3
>
> And here is my lilo.conf:
> # Begin /etc/lilo.conf
> boot   	   = /dev/hda
> message    = /boot/message
> vga	   = normal
> default    = linux
> install    = /boot/boot-menu.b
> menu-title = "How may I serve You?"
> lba32
> compact
> read-only
> prompt
> timeout	= 10
>   image  = /boot/vmlinuz
>   label  = linux
>   root   = /dev/hda4
>
>   image  = /boot/lfskernel
>   label  = lfs
>   root   = /dev/hda3
>   read-only
> # End /etc/lilo.conf

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list