Network configuration problem

Frank Langtind frank at langtind.no
Tue Dec 12 08:59:00 PST 2000


At 12:08 12.12.2000 +0000, you wrote:
>Hi
>
>I tried to setup the network as LFS said, but I received the following
>errors on boot-up:
>
>Brining up the eth0 interface...SIOCSIFADDR: No such device
>eth0: unknown interface: No such device
>netmask: Host name lookup failure
>SIOCSIFADDR: No such device
>eth0: unknown interface: No such device
>
>And MAKEDEV says it doesn't know how to create 'eth'.
>
>Thanks.
>Shlok
>

I had the same problem when I tried to configure the NIC. The device driver 
was compiled as a module and the problem was that the module was not 
loaded. I fixed this by inserting the following into /etc/modules.conf 
(create a file if it doesn't exist):
alias eth0 <driver name>

In my case the driver was called rtl8139.  The next time I booted, the 
network worked just fine.

Frank


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list