Different LILO blues solved

Brad Hartin bhartin at satx.rr.com
Wed Dec 13 18:36:00 PST 2000


Just for the morbidly curious, I figured I'd put this little note on
record as I found *no* resources on the net that helped solved my problem.
At least this way this might make it's way into search engines via the
archives.  This is, though, a VERY rare set of circumstances to cause
this.

I was getting a strange error while trying to get LILO to work on my new
LFS system.

#/sbin/lilo
Map segment is too big.
#

Diagnosis:  Mis-matched versions of LILO between my primary boot and my
LFS boot, largely brought about because I shared /boot between the two
installations.  The "/boot/map" file was from the old version of LILO,

Solution:  In my case, just install the same version of LILO, and make
sure the install updates the /boot/map file with the same version.

Background:  I had forgotten to mount /boot under the chroot'ed
environment.  I realized this prior to rebooting, so (stupidly) copied the
contents of $LFS/boot to /boot (the kernel was identical anyway), and ran
lilo (whose lilo.conf was already set correctly) from the primary
environment.  Result?  Bah, I should have known better...

Oh well...Again, this is rare, but I figured I'd mention this for the
benefit of that poor soul that runs into this again.

-----------------------------------------
Brad Hartin - bhartin at strafco.com
Communications Administrator
Straus-Frank Enterprises Limited
Carquest retail/wholesale distributor for
areas in TX, OK, LA, AR, NM, and KS


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list