proftpd

Shlok Smári Datye shlok at ript.net
Fri Dec 15 05:22:23 PST 2000


Hi

I'm trying to set up anonymous FTP server using proftpd. I have tried using
the default anonymous.conf but that didn't work. Then I tried to modify it
to following:

ServerName                      "ProFTPD Default Installation"
ServerType                      standalone
DefaultServer                   on

# Port 21 is the standard FTP port.
Port                            21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask                           022

MaxInstances                    30

# Set the user and group that the server normally runs at.
User                            root
Group                           nogroup

<Anonymous /home/ftproot>
LoginPasswordPrompt off
UserAlias anonymous nobody
UserAlias ftp nobody
AuthAliasOnly off
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>

But still, it doesn't work. Anyone know what's wrong? Well proftpd program
works, but I can't login to my server. A message appears and tell me
"incorrect login".
Do I have to create new users or groups?

Thanks.
--
Shlok Smári Datye
http://shlok.ript.net/


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list