ppc support again?

Florin Boariu florin at bnv-bamberg.de
Tue Dec 19 10:00:31 PST 2000


> I have a ATI Rage 128 on my PC comp. Have you tried setting the driver to
> "r128" in X1186Config file?
> Could you post the errors you get?

Meanwhile, after endless tries and cruel resets followed by masses of
forced fsckecks, it finally runs -- almost.

Most of the time the errors were something like "no screens found", or the
display simply remained black. Tha latter in case of setting up a symlink
X->Xvfb.

Then I tried a utility xf86cfg which hangs around in my X11/bin. I'm not
quite sure, I assume some autoprobing. It made me turn the machine off
several times: I heard something was going on since there were some
read-operations from the HDD, but then the screen just turned into funny
white-tones (it's a laptop -- might that be the cause?)Anyway, after doing
this, there was a /root/XF86Config.new file around. I replaced the
XF86Config created by xf86config before with the new file. I restarted X
and again, the same white tones => forced reboot again.

I edited the file by hand and replaced the Driver "r128" part by Driver
"fbcon" (the module fbdev_drv.o brought me to this idea, aswell as an
outdated Framebuffer-HOWTO).

So X starts up just fine right now, and so do twm and IceWM, but I cannot
start an xterm. And that's pretty annoying. Could this be related to the
console-switching problem I already posted (I cannot switch consoles with
ALT+F<x>)?

best regards,
florin.


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list