installing "ed"

Rudolf Floers r.floers at web.de
Tue Dec 26 17:25:28 PST 2000


On Tue, Dec 26, 2000 at 04:27:38PM -0400, Lab Monkey wrote:
> hello everyone.
> i'm having troubles installing 'ed-0.2' (chapter 06, sec. 07)
> i keep getting this error message:
> 
> ed.h:241: conflicting types for `sys_errlist'
> /usr/include/stdio.h:557: previous declaration of `sys_errlist'
> buf.c:23: warning: `rcsid' defined but not used
> make: *** [buf.o] Error 1
> 
> i'm new to linux, so if anyone cares to answer this query, please keep it simple (i.e. dumb)

i never had a problem with ed so far, sth else might be wrong.

but i've run into that "previous declaration of `sys_errlist'"-problem with other packages.

one thing you can do, is:

cd /usr/include
mv stdio.h stdio.h.orig
sed s/sys_errlist/sys_errlist2/ stdio.h.orig > stdio.h

then after compiling your package, 
restore the orginal stdio.h.

cd /usr/include
mv stdio.h.orig stdio.h

but i'm not a programmer, so i don't know if that is such a good idea...

hth



-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list