installing perl-5.6.0

Lab Monkey labmonkey at hfx.eastlink.ca
Fri Dec 29 09:53:02 PST 2000


hello.
earlier in the week, i was asking for help installing "ed"
that worked out great, and i am very grateful for all the help i
recieved. thank you all very much.

now for today's crisis:
while installing perl, i got this message when i tried to run 'make'

`sh  cflags libperl.a miniperlmain.o`  miniperlmain.c
          CCCMD =  c++ -DPERL_CORE -c -fno-strict-aliasing
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3   
In file included from perl.h:513,
                 from miniperlmain.c:12:
/usr/include/string.h:247: parse error before `('
/usr/include/string.h:248: parse error before `('
/usr/include/string.h:253: parse error before `('
/usr/include/string.h:256: parse error before `('
make: *** [miniperlmain.o] Error 1

the default setup wanted to use [cc] for the compiler, but it claimed
that i didn't have that. so i set it to use [c++] instead. so i strongly
suspect this problem is a case of me fooling around with things i don't
understand :)

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list