After chroot

Joel Farley jfarley at copperz.com
Thu Jun 1 12:37:41 PDT 2000


Hi:

I'm building LFS from the 2.3.3 nochunks book.  I have a couple of
questions:

After I chroot to the new partition and start to build ed I get gcc 2.95.2
errors about missing /usr/include/Linux and /usr/include/asm components.
After the three-fingered salute, I copied these directories in from my base
system and everything works fine.  These components don't seem to get
created in the LFS world until I install the kernel a little farther down
the book.  Is copying these files OK?

The last install before chroot was textutils.  I noticed that the cookbook
entry differed from the others - they were installed into my base system
rather than my LFS system.  I ran the usual LFS pattern to install them in
the LFS partition.  Is that what you have in mind?

In the static build portion of the book, I kept getting link errors with the
various regex.c modules.  The patches all failed.  So I changed
re_max_failures in each module to static and the compile and link worked
fine.  I rebuild from the tar in the dynamic portion so this hack will go
away.  Is this coloring still within the lines?

Thanks for LFS - I haven't had this much fun in a long time.

Joel Farley
CopperZ


--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list