After chroot

Gerard Beekmans gerard at linuxfromscratch.org
Thu Jun 1 13:34:44 PDT 2000


> After I chroot to the new partition and start to build ed I get gcc 2.95.2
> errors about missing /usr/include/Linux and /usr/include/asm components.
> After the three-fingered salute, I copied these directories in from my base
> system and everything works fine.  These components don't seem to get
> created in the LFS world until I install the kernel a little farther down
> the book.  Is copying these files OK?

not really, but if you copied recent files it should be ok. I mean: if
your normal distro has a recent kernel tree it (2.2.x) it shouldn't be a
problem.
 
> The last install before chroot was textutils.  I noticed that the cookbook
> entry differed from the others - they were installed into my base system
> rather than my LFS system.  I ran the usual LFS pattern to install them in
> the LFS partition.  Is that what you have in mind?

was my mistake (i put in the wrong sgml command, causing the dynamic
version of the file to be pasted into that section).
Where it reads:
&c5-pp-textutils;
it should have read:
&c5-pp-textutils-static;

this has been fixed in the upcoming 2.3.4 EFR.
 
> In the static build portion of the book, I kept getting link errors with the
> various regex.c modules.  The patches all failed.  So I changed
> re_max_failures in each module to static and the compile and link worked
> fine.  I rebuild from the tar in the dynamic portion so this hack will go
> away.  Is this coloring still within the lines?

Patches failed in what way?

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list