Boy, am I havin' trouble!

Tony Karakashian tonyk at monstertruck.cc
Sat Jun 3 08:28:57 PDT 2000


> On Sat, Jun 03, 2000 at 12:41:22AM -0400, Tony Karakashian wrote:
> > Okay, so I haven't gotten very far..I just installed init,
> and configured it  and lilo and rebooted.  It comes back with a kernel
panic
> that it can't "find an init supply init= at boot prompt".  I
> double-checked, init's there in /sbin, and I setup my inittab as per the
book, so, what
> the dilly?
>
> Did you specify the Root-Device in your lilo.conf?
> Like
>
> image = /mnt/lfs/boot/bzImage
> root = /dev/hda3
> label = lfs
>

Yup.

A little more info:  I had a 400M hard drive lying around before I started
this project.  Actually, I'd started by trying to get one of the bloated
distros to FIT usefully on the 400M drive, and found that starting from
scratch would be a better way to go.  Anyone that says Windows is bloated
obviously hasn't tried installing RedHat or Mandrake lately. :)  Anyway...so
LFS is on this second drive (/dev/hdc).  Could THAT have something to do
with it?  I don't have a /boot partition, and am using my current kernel
which is located on the first HD.

Thanks,

-T


--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list