DLD 6.0 to LFS - log

Erika Pacholleck Pacholleck.E at knuut.de
Sun Jun 11 05:15:23 PDT 2000


This is a short log of how to do it. A very adventurous way but worked.
Maybe there´s some hints for people who run into trouble.

DLD versions: kernel-2.0.36, libc-2.0.7, gcc-2.7.2.3, gettext-0.10, alien-6.18
LFS documents: all I could get
------
problems:
1. chroot does not work: permission for /dev/null denied, solved: boot LFS
2. always complaints about too old versions, solved: all static first
3. lilo cannot boot new kernel: wrong version, solved: boot old first

1. Compile all static in DLD (HOWTO-1.3)
-. autoconf, automake, binutils, bison, diffutils, filetutils,
-. findutils, grep, gzip, ld.so, m4, make, mawk, perl,
-. sed, sh-utils, tar, textutils, texinfo, util-linux, sysvinit,
-. gettext, bash-1.14.7 to /usr/local/bin, bash-2.04 to /bin
-. copy lib_nss files (BOOK-2.2.3)
1. write /etc/fstab, inittab, group, passwd (BOOK-2.2.3)
1. copy kernel to /LFS/boot
1. update DLD-lilo
-. you can than boot an use LFS 
>. (if german) prewrite scripts in LFS/root mod 600 because of kbd layout
------
problems:
1. find not compiling, solved: get readycompiled static (diylinux.com)
2. gettext only dynamic, solved: copy ld-2.0.7, libc-2.0.7 and links to LFS

2. change in DLD (tgz and static to /local, no mixing into rpm):
-. compile static gcc-2.95.2 to DLD/usr/local/gcc2952 (BOOK-2.2.3)
-. rpm -e gettext
-. compile dynamic gettext-0.10.35 to /DLD/usr/local
-. link all /usr/local/gettext stuff into /usr

3. in LFS: make installkernel (all in, no modules)
4. than link kernelsources

5. use DLD: rename LFS/bin/bash to bash204
-. link LFS/bin/bash and sh to LFS/usr/local/bin/bash (the 1.14)
6. copy /usr/local/gcc2952 to LFS and link to /usr

BOOK-2.2.2-4 instructions, mailinglist and its archive
idea RH glibc from diylinux.com (old version), carefully thought over

7. compile glibc
------
problems:
!!. carefully check naming of /lib/files of your distribution versus RH first !!
-. (and: yes, I know you should not alien basic system data)
1. static gcc test failed (what the hell is a "normal value"?), solved: 
-. rename /lib, /usr/lib, /usr/include, /usr/share, to <dir>-dld
-. get RH glibc´s.rpm, alien, untar, delete all uneccessary, copy to LFS
-. link <dir>-dld into /lib, /usr/lib, /usr/include, /usr/share (now from RH)
2. exit: not enough space, solved: sources on other partition, link partition
>. data: glibc-sources=43.308, glibc-build=244.249 (df values) glibc-tmp=?
>. data: iP200, 96RAM, 2x128swap, disable-nls (faster), time: ca. 2.5-3 hours
3. install glibc needs fresh dirs again
-. rename /lib, /usr/lib, /usr/include, /usr/share, to <dir>-rh
- link <dir>-rh into new made /lib, /usr/lib, /usr/include, /usr/share (glibc)
-. make a list of existing status quo (helps if lost!)
4. install glibc overwrites some in <dir>-rh
-. make a list of installed status quo (helps if lost!)
-. mv the overwritten ones (links are now directories) from <dir>-rh to <dir> 
-. get rid of not longer used data in <dir>-rh (don´t delete links to <dir>-dld)
5. get more space again: strip debug symbols from binaries
>. data: 1.858 more

8. set back bash to 2.04 (remove link, rename bash204 to bash)
9. compile dynamic (LFS-BOOK-2.2.2 to 4) not chroot, boot LFS instead
-. ncurses, ed, patch, gettext, bison, autoconf, automake
-. mawk, less, findutils-lfs, gcc, perl, texinfo, bash, flex, file
-. binutils, bzip2, diffutils-lfs, fileutils, gzip, e2fsprogs, grep-lfs,
-. ld.so, libtool, linux86, groff, lilo-21.4.4, make, sh-utils, shadow,
-. modutils, procinfo, procps, ssd, sed, sysvinit, sysklogd, textuils,
-. tar, vim, util-linux, m4, psmisc
---------
problems:
1. m4 doesn´t pass check, solved for now: keep static
2. e2fsprogs assumes cc for compiling, solved: export CC=/usr/bin/gcc
-. checks failed: missing gzip, solved: install gzip first
3. gzip defines datadir=$(prefix)/lib, solved: change Makefile.in
4. linux86 assumes cc for compiling, solved: export CC=/usr/bin/gcc
5. psmisc just too much wrong, solved for now: postpone till end
6. m4 doesn´t pass check, solved: do NOT use option --host
7. psmisc assumes cc (also for preproc), solved: link cc to gcc
-. links with -ltermcap, solved: change Makefile to -lncurses

10. check with installing dates whether still old files there
-. than remove all old still remaining DLD stuff
11. in LFS build fully moduled kernel and install accordingly
12. write /etc/lilo.conf and run lilo
--------
problems:
1. menuconfig saves disabled values as enabled, solved: use config
2. lilo-21.4.2 can´t load 2nd-stage, solved: use version 4.4

13. /etc files which are left to do
-. nsswitch.conf, ld.so.conf, syslog.conf, sysvinit, 
14. other files left
-. /var/run/utmp, /etc/vim/vimrc (my location)
15. init scripts: for the moment copy from download area pcrdallas.com
--------
problem:
1. login: unable to change tty /dev/tty1 for user root, reason: 
-. forgot the /etc/init.d/functions

remarks:
1. gettext is used if you want messages in your own language
-. To use ready-made ones you do not need it, only if you want to
-. make your own translations
-. install it first, than compile faster: with-included-gettext=no, disable-nls 
2. termcap is in my system not present, all work is done by ncurses
-. this is test-phase still, if unsure better install termcap.
-. requires sometimes replacing Option -ltermcap with -lncures
3. man not yet installed, got to see first, how to force it into my dirs
4. as DLD is a german distri, detailed german description will soon be
-. be published on my webside.

Erika
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list