DLD 6.0 to LFS - log

Gerard Beekmans gerard at linuxfromscratch.org
Wed Jun 21 21:59:10 PDT 2000


> problems:
> 1. chroot does not work: permission for /dev/null denied, solved: boot LFS

or fix the permissions. chmod 666 /dev/null

> 2. always complaints about too old versions, solved: all static first

too old of what versions?

> 3. lilo cannot boot new kernel: wrong version, solved: boot old first

did you get an error from lilo saying it was expecting some other MBR
version? If so, you used the pre-2.3.4 way to configure lilo (the old
way overwrites the $LFS/boot/boot.b file)
 
> 1. find not compiling, solved: get readycompiled static (diylinux.com)

or download the findutils patch which fixes this too.

> 2. e2fsprogs assumes cc for compiling, solved: export CC=/usr/bin/gcc

i recommend creating the /usr/bin/cc symlink instead as the book tells
you to as well.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list