LFS upgrade problems

Hywel Mallett Hywel at hmallett.force9.net
Thu Jun 22 15:06:48 PDT 2000


I'm still having problems building a LFS 2.3.5b system from a LFS 2.2
system.
To recap, when I enter the chrooted environment, ed installs OK, then patch
makes OK, but when I make install, the result is:

bash-2.04# make install
/bin/sh ./mkinstalldirs /usr/bin /usr/man/man1
make: *** [installdirs] Segmentation fault

I think this may be stemming from a problem with glibc. During the configure
section of glibc, I get:

configure: warning:
*** An auxiliary program is missing or too old;
*** some features will be disabled.
*** Check the INSTALL file for required versions.

and /mnt/lfs/usr/src/glibc-build/config.log contains:

configure:2799: gcc -O3 -mpentium -march=pentium -nostdlib -nostartfiles -o
conftest conftest.c -lgcc >&5
/usr/i586-pc-linux-gnu/bin/ld: warning: cannot find entry symbol _start;
defaulting to 08048074
/tmp/ccyqsAdN.o: In function `foo':
/tmp/ccyqsAdN.o(.text+0xf): undefined reference to `__builtin_expect'
collect2: ld returned 1 exit status

I've checked the INSTALL file, and I have all the programs listed, so I
don't know what to try next really.
If nobody has any better ideas, I might try:

Install LFS 2.3.5b over the top of LFS 2.2, then build a 2.3.5b from that.
Reinstall Mandrake, then install LFS 2.3.5b from that.

If anybody wants to e-mail me their /mnt/lfs/usr/src/glibc-build/config.log
, feel free, so that I can compare with what I have.

TIA

--
Hywel Mallett


--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list