GLIBC Compile Problem

Ian Chilton ian at ichilton.co.uk
Sun Jun 25 01:09:35 PDT 2000


Hello,

I posted yesturday about a problem I was having with Glibc. Let me give more
details now.

It happens about 30 mins into the compile, so has taken a while to test
things. I have now tried to compile it about 7 times now. Arrrgh!

I am using LFS Book 2.3.5b, Glibc 2.1.3, with kernel 2.2.16 and PGCC 2.95.2
(GCC 2.95.2 with the Pentium Patch).


I have now tried the following:

- Re-Unpack, and try from scratch
- Re-Unpack, and apply patch
- Compile/Install GCC 2.95.2, re-unpack glibc, and try again
- Re-Unpack kernel, make menuconfig && make dep && make bzImage, then
re-unpack glibc and try again

Now, i've run out of ideas  :(


This is what I get, every time (about 1/2hr into the compile):

make  -C db2 others
make[2]: Entering directory `/lfs/src/glibc-2.1.3/db2'
gcc
common/db_appinit.c -c -O -Wall -Winline -Wstrict-prototypes -Wwrite-strings
 -g   -fPIC    -I../include -I. -I/lfs/src/glibc-build/db2 -I.. -I../libio  
-I/lfs/src/glibc-build -I../sysdeps/i386/elf -I../crypt/sysdeps/unix -I../li
nuxthreads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread -I../li
nuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix -I../linuxthread
s/sysdeps/i386/i686 -I../linuxthreads/sysdeps/i386 -I../sysdeps/unix/sysv/li
nux/i386/i686 -I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux
 -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysde
ps/unix/inet -I../sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv -I../sysdeps
/unix/i386 -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686 -I../
sysdeps/i386/i486 -I../sysdeps/libm-i387/i686 -I../sysdeps/i386/fpu -I../sys
deps/libm-i387 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee7
54 -I../sysdeps/libm-ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic  
-nostdinc -isystem
/usr/local/lib/gcc-lib/i686-pc-linux-gnu/pgcc-2.95.2/include -isystem
/lfs/usr/include -D_LIBC_REENTRANT -include
/include/libc-symbols.h  -DPIC   -DHAVE_LLSEEK=1 -DHAVE_SPINLOCKS=1 -DHAVE_A
SSEM_X86_GCC=1 -I./include -include ./compat.h -o
/lfs/src/glibc-build/db2/db_appinit.os
common/db_appinit.c: In function `__db_appname':
common/db_appinit.c:479: fixed or forbidden register 0 (ax) was spilled for
class AREG.
common/db_appinit.c:479: This may be due to a compiler bug or to impossible
asm
common/db_appinit.c:479: statements or clauses.
common/db_appinit.c:479: This is the instruction:
(insn 902 901 903 (parallel[
            (set (reg:SI 2 %ecx)
                (unspec:SI[
                        (mem:BLK (reg:SI 5 %edi) 0)
                        (const_int 0 [0x0])
                        (const_int 1 [0x1])
                    ]  0))
            (clobber (reg:SI 5 %edi))
        ] ) 424 {strlensi+1} (insn_list 901 (nil))
    (expr_list:REG_UNUSED (reg:SI 5 %edi)
        (nil)))
make[2]: *** [/lfs/src/glibc-build/db2/db_appinit.os] Error 1
make[2]: Leaving directory `/lfs/src/glibc-2.1.3/db2'
make[1]: *** [db2/others] Error 2
make[1]: Leaving directory `/lfs/src/glibc-2.1.3'
make: *** [all] Error 2




This is my method (from LFS 2.3.5b):

#  cd /lfs/src
#  Unpack glibc.
#  copy glibc addons and patch to glibc-2.1.3
#  cd glibc-2.1.3
#  unpack addons and patch
#  patch -Np1 -i glibc-2.1.3.patch
#  cd ..
#  mkdir glibc-build
#  cd glibc-build
#

../glibc-2.1.3/configure --prefix=/usr --enable-add-ons --with-headers=/lfs/
usr/include
#  make      <------  THIS IS WHERE IT DIES, AFTER ABOUT 1/2HR



Anyone have any ideas????


Thanks!


Bye for Now,

Ian


                     \|||/
                     (o o)
 /----------------ooO-(_)-Ooo----------------\
 |  Ian Chilton                              |
 |  E-Mail : ian at ichilton.co.uk              |
 \-------------------------------------------/

--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list