Problem Compiling

Gerard Beekmans gerard at linuxfromscratch.org
Sun Jun 25 13:45:27 PDT 2000


> I am building LFS 2.3.5b, and am in the 'building static software' stage,
> and having a problem with glibc 2.1.3.
> 
> I tried the patch, but that didn't seem to help...anyone have any ideas?

This is a nasty old error we have dealt with a long long time ago. You
said your binutils fixed it by using the latest 1.10.x version (isn't
binutils in 2.x?) I got the same errors several months ago when gcc-2.x
was used on a system that was running Glibc-2.0 (like 2.0.7 as most
glibc-2.0 systems do). LFS used to run with Glibc-2.0.7 and gcc-2.95.2.
Due to the problems you had I had installed gcc-2.7.2.3 as well. As you
see there are a few possibilities that can cause it, but I am wondering
which Glibc version are you running on that gcc-2.x system?



-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list