login problem

Chris Krough ckrough at yahoo.com
Sun Jun 25 16:18:14 PDT 2000


well..that solves that. as I read this I am in the process of starting from
scratch... oh well

thanks.


"Gerard Beekmans" <gerard at linuxfromscratch.org> wrote in message
news:20000625165605.G1239 at lfs.linuxfromscratch.org...
> > Here's my problem: When I reboot into the LFS system I get to the login
> > prompt, when I login I get nothing, no errors, no prompt, nothing. If I
> > "CTRL-C" it bumps me back tp the login prompt. So as far as I can tell I
am
> > logging in OK but there is no shell. If I chroot to the LFS system from
my
> > old system I can run /sbin/sulogin and /bin/login with no problems so
> > shadowing is working. I have checked and rechecked my inittab but can't
seem
> > to find the problem. Root uses /bin/bash as it's shell, and /bin/bash
works.
> > Any ideas?
>
> try passing init=/bin/bash to LILO when booting the LFS system and see
> if bash can start at all.
>
> > I am running linux-2.2.99-pre9. (which kicks ass cause it supports my
HPT366
> > AND SB LIVE!!)
>
> Don't use shadow'ing when using the unstable kernel trees (2.3.x or 2.4
> beta (aka 2.2.99-prex) or 2.4.x-testx). It will not work (countless
> people have reported that).
>
> --
> Gerard Beekmans
> www.linuxfromscratch.org
>
> -*- If Linux doesn't have the solution, you have the wrong problem -*-


--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list