the prefix '/dev'

Gerard Beekmans gerard at linuxfromscratch.org
Thu Jun 29 12:41:41 PDT 2000


>     Now my LFS system almost works, but there are somewhat strange things.
>     One thing is the prefix '/dev' shown in 'w' command.
> 
> bash-2.04$ w
> 10:11pm  up 14:53,  2 users,  load average: 0.07, 0.03, 0.00
> USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU  WHAT
> flips    /dev/tty -                 7:19am  0.00s  1:03   0.00s  sh /usr/X11R6/b
> flips    pts/4    localhost         7:23pm  9.00s  0.09s  0.06s  telnet load 
> 
> 
>     /dev/pts/4 is shown as 'pts/4', but /dev/tty0 is shown with the
>     prefix '/dev'. Why? What's wrong? How can I correct it?  (I want
>     to eliminate '/dev')

I'm not sure if this has been answered. If so, then the person didn't leave 
the message-id intact so the respons didn't appear as a thread...

To get rid of /dev/ edit /etc/inittab. Find these lines:

1:2345:respawn:/sbin/agetty /dev/tty1 9600
2:2345:respawn:/sbin/agetty /dev/tty2 9600
3:2345:respawn:/sbin/agetty /dev/tty3 9600
4:2345:respawn:/sbin/agetty /dev/tty4 9600
5:2345:respawn:/sbin/agetty /dev/tty5 9600
6:2345:respawn:/sbin/agetty /dev/tty6 9600

Change them to:

1:2345:respawn:/sbin/agetty tty1 9600
2:2345:respawn:/sbin/agetty tty2 9600
3:2345:respawn:/sbin/agetty tty3 9600
4:2345:respawn:/sbin/agetty tty4 9600
5:2345:respawn:/sbin/agetty tty5 9600
6:2345:respawn:/sbin/agetty tty6 9600


-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list