Install-Report (LONG)

Thomas 'Balu' Walter tw at itreff.de
Fri Jun 30 12:18:26 PDT 2000


My first complete LFS-Install
A novel by Thomas "Balu" Walter ;)

Of course I will not explain everything in detail, but I will give
some ideas and or hints in addition to the 2.3.5b-book.

Starting with a working SuSE 6.4-installation I had to create a new partition.
I used "Partition Magic" to add a new one, but I was told that GNU parted
also works very well. The new partitition was /dev/hda4 located beyond 
the famous 1024 Cylinder of the HD, but the new LILO should not have 
any problems with that.

First "problem" I encountered was in "Compiler optimization". I was not
able to find possible cpu-identifiers. Of course the example i686 worked,
but I was courious about other possibilities...

Then I starting getting all necessary software, using freshmeat.net and
the content of the download-directories I watched for new versions - I 
found that

	MAKEDEV was not on FM 
	bash - you only need 2.04
	Linux Kernel 2.2.16 (Security-flaws in older ones)
	binutils 2.10.0.9,
	bzip2 1.0.1,
	make 3.79.1,
	util-linux - regarding to FM the main download is at 
		http://www.kernel.org/pub/linux/utils/util-linux/,
	mawk - could not be found on FM - requested an addition
	findutils - not on FM
	termcap - not on FM
	less 354 - FM-Download differs:
		http://www.flash.net/~marknu/less/download.html
	[perl - why do they call it stable.tar.gz? - uargh] 
	flex - not on FM
	file - login only by ftp-client (not with my netscape)?
	ld.so - FM-Download-Location:
		ftp://ftp.ods.com/pub/linux/
	lilo 21.4.4 - FM-Download-Location:
		ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
	shadow - FM-Download-Location: 
		ftp://piast.t19.ds.pwr.wroc.pl/pub/linux/shadow/
	modutils 2.3.11
	psmisc - not found on FM
	sysklogd - FM-Download-Location:
		http://freshmeat.net/redir/download/917481288/
	vim 5.7 - FM-DL: 
		ftp://ftp.home.vim.org/pub/vim/
	console-tools - FM-DL: 
		http://altern.org/ydirson/soft/lct/
	console-data - not found on FM
	net-tools 1.57

Starting to compile the first things I thought if Gerard sends all the
patches he (?) did to the packages to the actual maintainer of the 
packages [Now I know he wants to, but keeps forgetting :)]

I did not have to install gcc on my SuSE 6.4 - an 2.95.2 was already
installed. 

After unpacking the kernel I renamed it to another dir - as my SuSE
does it. I like to have the dirs called by their version-number:
	mv linux linux-2.2.16; ln -s linux-2.2.16 linux

"Installing Glibc" - Why do I have to copy the archives into the
unpacked glibc-dir? I just unpacked them there...
I also think you should show the command for creating glibc-build...
I noticed it after a second look - reading to fast :)
A nice way to create configparms (and some other files) is to use
cat, echo and such... If you add those commands to the script it's
easier to cutnpaste :)

	balu at Balu:# cat >configparms 
	# Begin configparms

	slibdir=/lib
	sysconfdir=/etc

	# End configparms 
	<ctrl-d>

The next two parts differ if you had a suitable gcc-version installed
or not - you'll better change the order of those sentences - it's easier
to get the point...:

	If your system already had a suitable GCC version installed change to
	the $LFS/usr/src/glibc-build directory and install Glibc by running the
	following commands

To find out wether I had to install old NSS-Library files I needed to check
the installed glib-version. The ls-"trick" did not work - I checked by
using rpm:

	root at Balu: > ls /lib/libc*
	/lib/libc.so.6  /lib/libcrypt.so.1
	root at Balu: rpm -q libc
	libc-2.1.3-58

"Installing Gzip" - while trying to mv gunzip gzip $LFS/bin I got a gzip -
file not found. Trying the same command again gave "gunzip not found".
Dunno why this happened, but after that both files were in /bin.

I needed the sed-patch.

To add to passwd and group-files I used:
echo "root::0:0:root:/root:/bin/bash">$LFS/etc/passwd
echo "root::0:">$LFS/etc/group

Meanwhile I got to the point where the static-packages got replaced by
their dynamic ones and I thought if I have to delete-re-untar 
everything - I did not check and used the easier method :).

I needed the findutils-patch. 

[I got a yacc not installed error here - I think I forgot to make install
bison... perhaps too much chatting on irc.linuxfromscratch.org? :) -
BTW: Thanks for your help, dudes!]

While configuring perl I was annoyed about answering all those questions.
Gerard didn't know an easier way, but I figured out that you can
	# ./Configure -Dprefix=/usr -d
It "Failed 13 test scripts out of 229, 94.32% okay."

Installing bin86 was not possible - I used
http://www.linuxfromscratch.org/download/linux86-0.14.3-lfs.tar.gz
and installed it with:
	# cd as; make && make install
	# cd ../ld; make ld86 && make install

Procinfo complained about missing -ltermcap: 
	# sed s/termcap/ncurses/ Makefile>A
	# mv A Makefile

psmisc - the same as procinfo...

To install shadow-passwording I did 
	# chmod 700 /etc/login.defs
	# cd /etc
        # /usr/sbin/pwconv
	# echo "shadow:x:15:root">>/etc/group
	# chown root.root passwd
	# chown root.shadow shadow
	# chmod 0644 passwd
	# chmod 0640 shadow

To load my german keymap - I decided to use
/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz
[After booting later I noticed that the äöüß-keys do not work - I
have to check that]

Mine fstab looks like this (because of my hda4-LFS-partition):
BTW - I used the same swap as the SuSE-System..

	# Begin /etc/fstab

	/dev/hda4 / ext2 defaults 1 1
	/dev/hda2 none swap sw 0 0
	proc /proc proc defaults 0 0

	# End /etc/fstab  

Net-tools still contains a bash-2.03 part and it asks for many questions
while making... Perhaps add a note that the defaults are okay.

While compiling the kernel don't use any modules! Even don't try to
use the "loadable module support" - gives error on booting, because
of missing module-dependencies and such - you need a modules.conf in
/etc, I think...

Lilo complained about the famous 1024 Cylinder-problem - after searching
a little I found that I needed to call it "lilo -L" to get beyond this.
But it still complained about:
	Fatal: VGA mode presetting is not supported by your kernel.
I was not really sure what this is about - I activated the vga-thingie
in menuconfig...
Putting a "#" in front of the following line in lilo.conf helped:
	vga = normal    # force sane state

After that - I rebooted, entered LFS at boot prompt and - 

			voila - it worked!

Thanks to all who helped...

     Ba-finetuning.the.rest.now-lu
PS: Those rc-scripts need a "status"-function to be LSB-compliant, correct?
--
Mail archive: http://www.pcrdallas.com/mail-archives/lfs-discuss
IRC access: server: irc.linuxfromscratch.org port: 6667 channel: #LFS
Unsubscribe: email lfs-discuss-request at linuxfromscratch.org and put
"unsubscribe" (without the quotation marks) in the body of the message
(no subject is required)



More information about the lfs-dev mailing list