error on "make install" util-linux

ken_i_m ken_i_m at elegantinnovations.com
Thu Nov 2 12:07:55 PST 2000


Tried editing the /etc/group file - replacing the x with ! > no go
logout and back in to possibly reset environment variables (most likely a 
pointless exercise leftover from too much time with Windoze) > no go
Went through page to install shadow passwords again. Watched screen closely 
during this but didn't see any error messages or other indications of 
things gone amiss.

bash# whoami
root
bash# groups
root bin sys kmem tyy daemon 10

I was a little confused about exactly how to edit the MCONFIG file for the 
util-linux install. Partly because what I see in the file I have does not 
look exactly like the example in the book. This is what I have and did:

# Different optimizations for different cpus.
ifeq "$(ARCH)" "intel"
   ifeq "$(CPU)" "i386"
     OPT=         -pipe -O2 -i686 -fomit-frame-pointer
   else
     OPT=          -pipe -O2 -m486 -fomit-frame-pointer
   endif
else
   ifeq "$(ARCH)" "arm"
......

The "i686" is what I changed from the "-m486" that was there. I don't know 
why that would have any effect on the validity of the "tty" group . . .


At 07:42 PM 11/2/00 +0100, you wrote:
>the x in "tty:x:4:" indicates the use of shadow passwords.
>could a faulty shadow password suite be the problem?
>try replacing the x with ! (exclamation mark)
>! means: password is empty line and shadow passwords are not used.
>i'm not sure if passwords are actually checked when you run make,
>but i think it's worth a try.
>
>hth
>
>On Thu, 02 Nov 2000 07:35:48 -0700, ken_i_m 
><ken_i_m at elegantinnovations.com> wrote:
> >
> > /etc/group
> >
> > root:x:0:
> > bin:x:1:
> > sys:x:2:
> > kmem:x:3:
> > tty:x:4:
> > uucp:x:5:
> > daemon:x:6:
> > floppy:x:7:
> > disk:x:8:
> >
> > Well, I didn't miss creating the files.
> >
> > At 09:07 AM 11/2/00 +0100, you wrote:
> >>( Don, 02 Nov 2000 ) ken_i_m <-- :
> >> > cchgrp tty /usr/bin/write
> >> > chgrp: invalid group name `tty'
> >> > make[1]: *** [install] Error 1
> >> > make[1]: Leaving directory `/usr/src/util-linux-1.10o/misc-utils'
> >> > make: *** [install] Error 1
> >>
> >>Chapter 5, Creating passwd and group files:
> >>this is where you create the tty group.
> >>
> >>About missing: when I built my first lfs I used this very
> >>effective but oldfashioned way with a sheat of paper and
> >>a pen ;-)
> >>
> >>Erika
> >>
> >>
> >>--
>
>--
>Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
>and put unsubscribe in the subject header of the message

I think, therefore, ken_i_m


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list