make LDFLAGS=-static gives error "undefined reference to `getloadavg'"

greg scott snoop at linuxfreak.com
Fri Nov 3 23:13:40 PST 2000


Gerard,

thx very much for the help!

i must have carelessly installed the wrong libc6 (ie. woody rather
than potato).

the problem cleared after going to libc6 2.1.3-10.

it might help others to mention that doing a "make clean" in the
make-3.79.1 directory after going back to libc6 2.1.3-10 wasn't
enough--the error still occurred.  i had to remove the directory and
unpack make-3.79.1.tar.bz2 to get a clean start.

thank you for your guidance.

greg scott


On Fri, Nov 03, 2000 at 10:25:26AM -0500, Gerard Beekmans wrote:
> > the only thing i know relating to glibc is the debian libc6 packages.
> > even the debian unstable is only  libc6 2.1.95-1, so where would i
> > look for glibc2.2?
> >
> > as for whats on my debian stable (potato), i have:
> > ii  libc6	2.1.95-1	GNU C Library: Shared libraries and Timezone data
> > ii  libc6-dev	2.1.3-10	GNU C Library: Development Libraries and Header
> > Files.
> 
> Right, Glibc-2.1.95 are the alpha glibc versions that eventually become 
> Glibc-2.2
> 
> > are there any any further commands to provide info for getting at the
> > suspected problem with my static C library?
> 
> Install redhat 6.x that uses a Glibc-2.1.x setup which isn't alpha software
> 
> -- 
> Gerard Beekmans
> www.linuxfromscratch.org

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list