binutils

fre at wenglor.de fre at wenglor.de
Tue Nov 7 00:52:48 PST 2000



Hi,
as I tried to install binutils with shared libraries I got the following linker
error:

/bin/sh ./libtool --mode=link gcc  -O2 -mcpu=i486 -march=i486  -o size  size.o
bucomm.o version.o filemode.o ../bfd/libbfd.la ../libiberty/libiberty.a  gcc -O2
-mcpu=i486 -march=i486 -o .libs/size size.o bucomm.o version.o filemode.o
.../bfd/.libs/libbfd.so ../libiberty/libiberty.a
size.o: In function `usage':
size.o(.text+0x3a): undefined reference to `dcgettext__'
size.o(.text+0x86): undefined reference to `dcgettext__'
size.o(.text+0xe8): undefined reference to `dcgettext__'
size.o: In function `main':
size.o(.text+0x259): undefined reference to `dcgettext__'
size.o(.text+0x2f5): undefined reference to `dcgettext__'
bucomm.o(.text+0x172): more undefined references to `dcgettext__' follow
collect2: ld returned 1 exit statusmake[3]: *** [size] Error 1
make[3]: Leaving directory `/usr/src/binutils-2.10/binutils'make[2]: ***
[all-recursive] Error 1
make[2]: Leaving directory `/usr/src/binutils-2.10/binutils'make[1]: ***
[all-recursive-am] Error 2
make[1]: Leaving directory `/usr/src/binutils-2.10/binutils'make: ***
[all-binutils] Error 2

As I configured with disable-nls all worked fine.

Any ideas, comments ???

Franz



-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list