binutils

Thomas 'Balu' Walter tw at itreff.de
Tue Nov 7 01:50:21 PST 2000


+-fre at wenglor.de-(fre at wenglor.de)-[07.11.00 10:06]:
> as I tried to install binutils with shared libraries I got the following linker
> error:
> 
> /bin/sh ./libtool --mode=link gcc  -O2 -mcpu=i486 -march=i486  -o size  size.o
> bucomm.o version.o filemode.o ../bfd/libbfd.la ../libiberty/libiberty.a  gcc -O2
> -mcpu=i486 -march=i486 -o .libs/size size.o bucomm.o version.o filemode.o
> ../bfd/.libs/libbfd.so ../libiberty/libiberty.a
> size.o: In function `usage':
> size.o(.text+0x3a): undefined reference to `dcgettext__'
[...]
> 
> As I configured with disable-nls all worked fine.
> 
> Any ideas, comments ???

My idea is to use --disable-nls again :) The "undefined reference to
dcgettext__" looks like you are missing the gettext-library - which is
needed for NationalLanguageSupport - NLS. 

If you disable that it should work just fine.

     Ba-germanize.this-lu

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list