BUGTRAQ alert - [SECURITY] [DSA-001-1] ed symlink attack

Matthias Benkmann mbenkmann at gmx.de
Wed Nov 29 13:53:53 PST 2000


X
> This showed up in my mailbox just minutes after I finished install ed in my 
> new lfs. Is ed even needed anymore? I wouldn't know how to use it if I had to.

You don't need vim or ed. Just install whatever editor you like. I only 
installed joe for instance.

BTW, I think the editor installation should already be in the static build 
part (chapter 5) and because choosing an editor is a matter of personal 
taste, the book shouldn't just present vim and ed as if they were a 
necessary part of the system. The paragraph should rather say:

"Installing an editor

Depending on your preferences you can install one or more of the following 
editors."

And then installation instructions for several editors would be given. vim 
and ed are already present, I can contribute the joe part (the Makefile 
needs a few patches) and a pico user can contribute the pico build 
instructions (I guess that requires some work to extract it from the pine 
package).


MSB

p.s.: joe has a pico and an emacs mode

----
Vacuum cleaners suck!


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list