Diffutils-2.7

Clark Ashton Smith CAS at FutureRealms.com
Thu Nov 30 10:12:47 PST 2000


Clark Ashton Smith wrote:
> 
> Gerard Beekmans wrote:
> > Try this:
> > sed s/re_max_failures/re_max_failures2/ regex.c >regex-new.c
> > mv regex-new.c regex.c
> >
> > now compile it again. The CPPFLAGS that's set before you run the configure
> > script is supposed to do that, but apparently your compiler (actually the C
> > PreProcessor (cpp) doens't listen to it or somehow bash doesn't pass the
> > variable properly (it happens very ocasionally).
> >
> > --
> > Gerard Beekmans
> 
> I'm on SuSE 6.4 and had the same error. Deleting the
> diffutils' source dir and unbzipping it again did not
> help. Using Gerard's sed fix worked.  Thanks.
> 
> --
> Lost Worlds
> CAS

I took another look at LFS-BOOK-INTEL-2.4.3-HTML
Installing Diffutils and I saw where I went wrong.

    CPPFLAGS=-Dre_max_failures=re_max_failures2 \
       ./configure --prefix=$LFS/usr --disable-nls &&
    make LDFLAGS=-static &&
    make install

My mistake was this:
First I set the  CPPFLAGS and then as a separate command
I ran ./configure

When I ran CPPFLAGS=... and ./configure on the same 
command line, as you indicated in your guide, there was 
no problem and I did not need to use the sed fix.  Just 
thought I'd pass my mistake along.  It might help someone 
else.
 

--
Lost Worlds
CAS

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list